Issue

There is no Amazon payment button on the invoice.

Cause

The problem is mostly related to a misconfiguration of the module. The module logs all errors returned by Amazon to the gateway log of WHMCS:

For some configuration errors, the problem is logged to the browser console: 

Solution

To resolve the issue, open the invoice as a logged in customer and then view the WHMCS Gateway Log and browser console. The error messages are usually very clear, so you can immediately see what the problem is and how to fix it.

Please note that if you contact our support about an error, it is unlikely that we will be able to help, as the error messages come directly from Amazon and are usually caused by incorrect configuration of the credentials. We recommend that you contact Amazon first, as they have more insight into the logs and can tell you why you are seeing the error message. If you do not get any error message from the WHMCS Gateway Log and from the browser console, please get in touch with our support team.